Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux nVidia looks like jack hammer
05-22-2014, 04:16 AM, (This post was last modified: 05-22-2014, 04:37 AM by {DO}Rigel.)
Post: #11
RE: Linux nVidia looks like jack hammer
I've been doing some testing with regard to the CPU, GPU, usage and temperature in Windows vs Linux. For me, as of now, Windows is WAY smoother and clearer. However, that really wasn't what I was testing.

Linux:
Before game
CPU: 98 degrees F, with 20-30% usage each core about the same.
GPU: 58 degrees C, and I can't measure usage in Linux, fan about 2000 RPM

During game
CPU 110 degrees F, with ~70 - 80% usage both cores about the same
GPU 60 degrees C, fan about 2000 RPM

After game
returned to the same as before after about 5 min


Windows 7
Before game
CPU I cannot measure temperature in Windows, around 20% usage (drops under 10, spikes over 50, lots of irregularity)
GPU 58 degrees C, with 40% usage, fan about 2000 RPM

During
CPU, core1 100% and core2 50-60, total 70-80%
GPU just under 70 C, with 33% usage, fan 2000 RPM

After game
returned to the same as before after about 3 min

So its about the same for each OS - which is what I expected. Because it works well in Windows, I'm going to rule out a heat problem and processor load (CPU and GPU).

Next I will swap the 9800 GTX+ from my son's nearly identical system which works well under Linux and test it in mine.


Edit:
Just dropped the 9800 GTX+ in and confirmed that it runs as smooth as it does on my son's PC. Either I have a bad 460 or I have to do something to the config.

The linux driver supports both the GTX 460 and the 9800 GTX so I didn't need to change a thing.

Any further ideas would be appreciated. I have not yet looked at the doc strat posted, I will soon.
[Image: dorig.png](Art by {OS}Drastic)
system specs in profile
Reply
05-26-2014, 06:09 PM, (This post was last modified: 05-26-2014, 07:26 PM by {DO}Rigel.)
Post: #12
RE: Linux nVidia looks like jack hammer
Big Grin I am EXTREMELY HAPPY to report, I think I have solved this problem Big Grin

In nvidia-settings there is a tab for "PowerMizer" where you will find a dropdown list for your "Preferred Mode." You want to make sure that is set to "Prefer Maximum Performance" and not on the default "Auto." You also want to make sure that it does not revert - as mine did!

Now my game is as fluid as my Windows partition, freeing me from my dependence on Microsoft! Woohoo - I'm so happy I can't stop smiling. Man what a drag that was, my card was acting like the worse POS ever because it was being limited to half the MHz its capable of.

Confused The server lag has not changed, and all of those other problems caused by the internet, and routing, and data centers, and host servers remain though - Hey, you can't win 'em all Tongue

See ya in the arena! Cool
[Image: dorig.png](Art by {OS}Drastic)
system specs in profile
Reply
06-09-2014, 07:17 PM,
Post: #13
RE: Linux nVidia looks like jack hammer
In Linux the nVidia Control Panel settings aren't persistent over reboots. You can make it persistent in a number of ways, one common one is this at startup:

Code:
nvidia-settings --load-config-only

If you are interested in controlling just the PowerMizer setting, this command sets it to "Prefer Maximum Performance"

Code:
nvidia-settings -a [gpu:0]/GPUPowerMizerMode=1

Changing the last number sets the mode you want accordingly:

0 = Adaptive
1 = Prefer Maximum Performance
2 = Auto

Hope this helps someone else. For what its worth my troubles have not gone away. Forcing PowerMizer to maximum peformance has helped but it is very clear to me that Windows is behaving far better - which I find extremely frustrating. If I ever get it figured out I'll certainly update here.
[Image: dorig.png](Art by {OS}Drastic)
system specs in profile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)