Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No response from masterserver
06-06-2014, 09:23 PM, (This post was last modified: 06-06-2014, 09:28 PM by JayVii.)
Post: #1
No response from masterserver
So I tried to set up a server for me and my friends and I got stuck at starting the server. I can connect to it, but nobody else can.
The reason for this is, that the server can't connect to the master-server as it constantly times out in the console.
I forwarded the portrange 27900-27910 on both TCP and UDP.

Console-output:
Code:
jan@debianbox:~$ alien-arena +set dedicated 1 +set game ctf +exec server.cfg
ln: failed to create symbolic link ‘/home/jan/.config/alien-arena/data1’: File exists
using /home/jan/.config/alien-arena/arena for writing
execing default.cfg
execing config.cfg
execing profile.cfg
======== CRX Initialized ========

execing server.cfg
Master server at 69.136.224.226:27900
Master server at 69.9.170.53:27900
Sending ping to 69.136.224.226:27900
Sending ping to 69.9.170.53:27900
==== InitGame ====
------- Server Initialization -------
0 entities inhibited
ACEND_LoadNodes: not found: ���������
ACE: No node file found, creating new one...done.
0 teams with 0 entities
-------------------------------------
No acknowledgement from master.corservers.com - re-resolving
Master server at 69.136.224.226:27900
No acknowledgement from master2.corservers.com - re-resolving
Master server at 69.9.170.53:27900
Sending heartbeat to 69.136.224.226:27900
Sending heartbeat to 69.9.170.53:27900
No acknowledgement from master.corservers.com - re-resolving
Master server at 69.136.224.226:27900
No acknowledgement from master2.corservers.com - re-resolving

Server.cfg:
Code:
set port 27900
set dmflags 1049936
set hostname "JayViis testserver"
set password "123random"
set website "http://red.planetarena.org" s
set Admin "JayVii" s
set maxclients 12
set ctf 1
set grapple 0
set timelimit 20
set fraglimit 0
set g_reward 50
set sv_maplist "ctf-frostbyte ctf-cryogenics ctf-extermination ctf-goregrinder ctf-invasion ctf-oblivion ctf-purgatory ctf-titan2k8 ctf-violator ctf-zion2k9"
set g_antilag 1
set sv_public 1
set logfile 1
set sv_downloadurl "http://martianbackup.com/sv_downloadurl"
set rcon_password ""
setmaster master.corservers.com master2.corservers.com
map ctf-frostbyte

Help is appreciated. Thanks in advance JayVii
Reply
06-06-2014, 09:39 PM, (This post was last modified: 06-06-2014, 09:40 PM by {DO}Rigel.)
Post: #2
RE: No response from masterserver
I believe you need to forward some ports in your firewall. 29700, 27901 and 27910 for starters. I would not set the port to 27900 in the server config, because I think AA uses that one. Set it to 27910 instead. I expect that should straighten out the problem.
[Image: dorig.png](Art by {OS}Drastic)
system specs in profile
Reply
06-06-2014, 09:45 PM, (This post was last modified: 06-06-2014, 10:06 PM by JayVii.)
Post: #3
RE: No response from masterserver
(06-06-2014, 09:39 PM){DO}Rigel Wrote: I believe you need to forward some ports in your firewall. 29700, 27901 and 27910 for starters. I would not set the port to 27900 in the server config, because I think AA uses that one. Set it to 27910 instead. I expect that should straighten out the problem.
I set the port to 27910 in the server.cfg now. however starting the server still gives me the 27900 port.

I start the server in terminal via
Code:
alien-arena +set dedicated 1 +set game ctf +exec server.cfg


EDIT:
okay i got it using 27910 now simply by changing the set master line to
Code:
setmaster master.corservers.com:27910 master2.corservers.com:27910

However the it still won't work:
Code:
jan@debianbox:~$ alien-arena +set dedicated 1 +set game ctf +exec server.cfg
ln: failed to create symbolic link ‘/home/jan/.config/alien-arena/data1’: File exists
using /home/jan/.config/alien-arena/arena for writing
execing default.cfg
execing config.cfg
execing profile.cfg
======== CRX Initialized ========

execing server.cfg
Master server at 69.136.224.226:27910
Master server at 69.9.170.53:27910
Sending ping to 69.136.224.226:27910
Sending ping to 69.9.170.53:27910
==== InitGame ====
------- Server Initialization -------
0 entities inhibited
ACEND_LoadNodes: not found: ���������
ACE: No node file found, creating new one...done.
0 teams with 0 entities
-------------------------------------
No acknowledgement from master.corservers.com:27910 - re-resolving
Master server at 69.136.224.226:27910
No acknowledgement from master2.corservers.com:27910 - re-resolving
Master server at 69.9.170.53:27910
Sending heartbeat to 69.136.224.226:27910
Sending heartbeat to 69.9.170.53:27910

The servers just time-out.
Reply
06-06-2014, 10:01 PM,
Post: #4
RE: No response from masterserver
The master server will always be on 27900, so the "Master server at 69.9.170.53:27900" lines will always be the same.
Quote:* maxtothemax is back
<maxtothemax> with a vengeance
<maxtothemax> and chips
<maxtothemax> and bean dip
Reply
06-06-2014, 10:08 PM,
Post: #5
RE: No response from masterserver
(06-06-2014, 10:01 PM)Max Wrote: The master server will always be on 27900, so the "Master server at 69.9.170.53:27900" lines will always be the same.
Ok thanks. But it still does problems with the server not connecting to the master-servers. I can't even ping them via terminal. it would just time-out. This might be a DDos-protection but at least my server should connect to the master-servers Confused
Reply
06-07-2014, 05:38 AM, (This post was last modified: 06-07-2014, 06:10 AM by [SiN]bAnfire.)
Post: #6
RE: No response from masterserver
sounds to me a setting in your router is blocking your server.
if e.g. the portforwarding is set wrong, the router makes a re-route
to another port, then the one set in your cfg.
what happens then, is that your server sends a ping to the master, but
the ping-reply form the master is re-routed to a closed port and no reply
is being received, showing "no reply from master".

if you like, you can jump into irc and we can try to help and fix this problem.

http://red.planetarena.org/forum/showthread.php?tid=32
Ban? Who Can I Ban???
Reply
06-07-2014, 11:22 AM,
Post: #7
RE: No response from masterserver
Alright, I'll jump into IRC tonight. I hope you guys can help me (:
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)