Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Performance tweaks
09-27-2017, 11:22 AM,
Post: #21
RE: Performance tweaks
(09-27-2017, 11:19 AM)Max Wrote: Video might not show it, if it's not recorded at a high enough framerate. I'll do my best though.

No worries - I see it, and know exactly what this is - it has to do with lerping - I explain it in another thread.
Reply
09-27-2017, 11:30 AM,
Post: #22
RE: Performance tweaks
Actually, the video shows the bot issues pretty well. Not uploading to YouTube in case YouTube downconverts the framerate.
http://meliaser.dyndns.tv/videos/2017-09...-25-51.flv
The slow walks look fine, but running and jumping look very jumpy. My framerates were very high the whole time.
Quote:* maxtothemax is back
<maxtothemax> with a vengeance
<maxtothemax> and chips
<maxtothemax> and bean dip
Reply
09-30-2017, 07:02 AM,
Post: #23
RE: Performance tweaks
(09-26-2017, 11:56 PM)Max Wrote: My system has roughly the equivalent of a GTX 960 (it's a GTX 970M, a mobile GPU roughly the same power as a 960.) I just did a quick runaround in the new ctf-frost, with maximum settings, and the lowest framerate I saw was 142. I added 7 bots and the framerate got into the 90s a couple times. I can do some profiling to see if there are any CPU bottlenecks on that map that would cause your C2Q to bog down (I have Skylake i7.)

I did notice that the motion of the bots was not smooth as they were running and jumping around. I was also able to see the camera shake problems. The easiest way to spot it was to get killed-- the slowly zooming death cam looked pretty bad.

For me, in Alien Arena, one core is constantly at 100% and the other cores are doing nothing. Is it possible to utilize the other cores as well?
Reply
09-30-2017, 07:53 AM,
Post: #24
RE: Performance tweaks
Benau wrote about in this thread.

Quote:BTW a not-sure-if bug...
In glw_imp.c Sys_SetCpuCore Method, you seem to always SetProcessAffinityMask to 1 
(sys_affinity->value is always 1), at least in my task manager crx.exe always uses only 1 core 
of all CPUs, is it intended?
Reply
10-01-2017, 03:07 AM,
Post: #25
RE: Performance tweaks
I had the same issue on an older cpu, if I had affinity set to anything but zero performance was greatly reduced and the sound system would fart and stutter.



Reply
10-01-2017, 05:05 AM,
Post: #26
RE: Performance tweaks
I'm playing Alien Arena on Ubuntu 16.04 (64 bit). I don't think I can set an affinity.
I think I have this for as long as I play it, but never had performance issues with it until now, it seems.
Reply
10-01-2017, 05:27 AM,
Post: #27
RE: Performance tweaks
Did you try setting sys_affinity to 1 and 0 to see if it made any difference?



Reply
10-01-2017, 06:44 AM,
Post: #28
RE: Performance tweaks
I just tried, I don't see a difference. But this var is only used in the windows code, glw_imp.c.
Reply
10-01-2017, 07:17 PM,
Post: #29
RE: Performance tweaks
(09-30-2017, 07:02 AM)jarhead Wrote: For me, in Alien Arena, one core is constantly at 100% and the other cores are doing nothing. Is it possible to utilize the other cores as well?
No, not really. Our renderer isn't really parallelizeable.
Quote:* maxtothemax is back
<maxtothemax> with a vengeance
<maxtothemax> and chips
<maxtothemax> and bean dip
Reply
10-01-2017, 08:51 PM,
Post: #30
RE: Performance tweaks
Yeah, I was using Windows when I had to do that.



Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)